stretchからbusterにしたらWordPressが壊れた?

Google Analytics的な所から500でblogが見ることができないエラーの警告が出ていたので対応した。

お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。

上記のようなエラーメッセージが表示されていた。

php-mysqlをインストールしたが解決されず。結局、apt autoremove php7.0で古いPHPを消してapt install php7.3で最新のPHPを入れることで解決した。どうもphp7.3用のphp-mysqlモジュールが入っているのにphp7.0で動いていたので読み込まれなかったようだ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です