net-radio-archiveが動かなくなっていた

よくわからずにrootでbundle installしていた付けが回ってきた(今更

あと、更新スクリプトでbundle installしていないっぽいのもまずかったかも

ともかく、正月から録音が完全に止まっていたという大惨事になっていた。

$ bundle
Fetching gem metadata from https://rubygems.org/……….
Using rake 12.3.0
Using concurrent-ruby 1.0.5
Using i18n 0.9.1
Using minitest 5.10.3
Using thread_safe 0.3.6
Using tzinfo 1.2.4
Using activesupport 4.2.10
Using builder 3.2.3
Using erubis 2.7.0
Using mini_portile2 2.3.0
Using nokogiri 1.8.1
Using rails-deprecated_sanitizer 1.0.3
Using rails-dom-testing 1.0.8
Using crass 1.0.3
Using loofah 2.1.1
Using rails-html-sanitizer 1.0.3
Using actionview 4.2.10
Using rack 1.6.8
Using rack-test 0.6.3
Using actionpack 4.2.10
Using globalid 0.4.1
Using activejob 4.2.10
Using mini_mime 1.0.0
Using mail 2.7.0
Using actionmailer 4.2.10
Using activemodel 4.2.10
Using arel 6.0.4
Using activerecord 4.2.10
Using activerecord-import 0.21.0
Using bundler 1.16.1
Using chronic 0.10.2
Using coderay 1.1.2
Using coffee-script-source 1.12.2
Using execjs 2.7.0
Using coffee-script 2.4.1
Using thor 0.20.0
Using railties 4.2.10
Using coffee-rails 4.0.1
Using unf_ext 0.0.7.4
Using unf 0.1.4
Using domain_name 0.5.20170404
Using hike 1.2.3
Using http-cookie 1.0.3
Using multi_xml 0.6.0
Using httparty 0.15.6
Using multi_json 1.12.2
Using jbuilder 2.7.0
Using jquery-rails 4.3.1
Using json 1.8.6
Fetching m3u8 0.8.2
Bundler::GemspecError: Could not read gem at
/var/lib/gems/2.1.0/cache/m3u8-0.8.2.gem. It may be corrupted.
An error occurred while installing m3u8 (0.8.2), and Bundler cannot
continue.
Make sure that gem install m3u8 -v '0.8.2' succeeds before bundling.
In Gemfile:
m3u8

$ bundle –path vendor/bundle で解決した(参考

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です